Scan my site freeScan free

Fix guides / Security notices

Security notice

WordPress store using FunnelKit Automations? A flaw rated 9.8 needs no login. Update to 3.8.6.2.

Last updated: Saturday, October 31, 2026, 12:44 PM ETStatus: Fix released. No attacks reported yet. Update now.

FunnelKit Automations is a WordPress and WooCommerce plugin for abandoned cart emails, follow-up emails and a customer contact list. WordPress.org shows more than 20,000 active installations. On October 30, 2026, security firm Patchstack, which assigned the CVE number, published a critical flaw in it: CVE-2026-39738, rated 9.8 out of 10. Versions up to and including 3.8.6.1 have an unauthenticated PHP object injection flaw, which Patchstack says lets attackers "manipulate how the site processes data to run harmful actions on the server," with no login needed. Version 3.8.6.2, released October 28, fixes it. CISA does not list it as exploited and we found no report of attacks, but Patchstack says flaws like this are "expected to become exploited" in mass attacks. If your site runs FunnelKit Automations, update to 3.8.6.2 or later today. The plugin's WordPress and PHP minimums did not change.

What happened

Who should worry

This is about WordPress websites, usually WooCommerce stores, that use the FunnelKit Automations plugin for abandoned cart emails or marketing automation. If you are not sure whether your site uses it, ask your web developer or agency. Ask about this if any of these are true:

If your site does not use FunnelKit Automations, this notice does not apply to you.

What to do now

Do these today.

  1. Check if you have it. In your WordPress dashboard, open Plugins, then Installed Plugins, and look for "FunnelKit Automations." Note the version number. If it says 3.8.6.2 or higher, you have the fix.
  2. Update. Update FunnelKit Automations to 3.8.6.2 or later. Take a backup first. Updating does not change the minimum WordPress or PHP version: WordPress.org lists WordPress 6.5 and PHP 7.4 as the minimums for both 3.8.6.1 and 3.8.6.2. (Patchstack, WordPress.org)
  3. If you cannot update today, ask your developer or host whether to deactivate the plugin until you can. That is general precaution, not FunnelKit's advice, and your automated emails will stop while it is off. (IONIX)
  4. Check for a break-in. No signs of attack have been published, so there is nothing specific to look for. As a general check, especially if you were on 3.8.6.1 or earlier for several days, ask your developer or host to look for administrator accounts you do not recognize, plugins you did not install and PHP files you did not put there.
  5. If you use FunnelKit Automations Pro, check your FunnelKit account for updates to it as well.
  6. Check your site afterwards. Test your abandoned cart emails and your checkout.

What to send your developer, agency or host

FunnelKit Automations (wp-marketing-automations) 3.8.6.1 and earlier has an unauthenticated PHP object injection flaw, CVE-2026-39738 (CVSS 9.8, assigned by Patchstack, published October 30, 2026). It is fixed in 3.8.6.2, released October 28. CISA does not list it as exploited, but Patchstack expects attacks. Please tell us whether our site runs this plugin and which version. If it is 3.8.6.1 or earlier, please update to 3.8.6.2 or later today, and tell us if you checked for unfamiliar administrators, plugins or PHP files. Sources: Patchstack, the CVE record, WordPress.org.

Common questions

Has my site been hacked?

This notice does not mean your site has been hacked. It means a critical flaw has been published and a fix is out. We found no report of attacks.

Can EverThread tell me if I am affected?

No. EverThread does not test for this. We check your home page from the outside, the way a browser sees it. We cannot see which plugins your site runs or which versions they are on, so if our scan does not warn you about this plugin, that does not mean you are safe. Our free scan does look at your home page for other common problems, such as an expired padlock certificate, missing browser safety settings and files that should not be public.

I updated on October 28 or 29. Am I covered?

If your plugin shows 3.8.6.2 or higher, you have the fix. Plugin updates can be turned off or fail, so check the version.

Does the update change my PHP or WordPress requirements?

No. WordPress.org lists WordPress 6.5 and PHP 7.4 as the minimums for both 3.8.6.1 and 3.8.6.2.

Is it being exploited?

We found no report that it is, and CISA does not list it. Patchstack expects it to be exploited, and the fix has been public since October 28. (Patchstack)

Where can I follow official updates?

Patchstack and the WordPress.org changelog. All current notices are on our notices page.

Security alerts by email

Hear about the next one first.

When a flaw puts websites at risk, we send one plain-English email: what happened, who it affects and what to do. It's free, whether or not you use EverThread.

We email you a link to confirm first, and every alert has a one-click unsubscribe. Alerts can include a short note about EverThread. Already a customer? Use your account email and your alerts include a link to your dashboard. Privacy

Sources

While you are here

Check your site's other basics free. We look at your home page the way a browser does and tell you in plain English. This scan cannot see which WordPress plugins your site runs or which version they are on. No account.

Or sign up free and we check it every day and email you when something changes.