Scan my site freeScan free

Fix guides / Security notices

Security notice

WordPress site using Gravity Forms? A flaw rated 9.8 needs no login. Update to 3.1.3 or later.

Last updated: Sunday, November 1, 2026, 9:43 AM ETStatus: Fix released. Reported exploited, not confirmed. Update now.

Gravity Forms is a paid WordPress plugin for building forms, and Censys counts about 83,800 web properties running it. On October 29, 2026, security firm Patchstack published a critical flaw in it, and the CVE record, assigned by Wordfence and published October 30, rates it 9.8 out of 10. In versions up to and including 3.1.2, a stranger with no login can use a public form to plant booby-trapped data in your site's database. It applies only to forms that create WordPress posts and use one particular kind of custom field, and whether it leads to a full takeover depends on your other plugins and themes and on your host's settings. Version 3.1.3 fixes it and was released October 1, so a site that has updated since then is covered. Patchstack labels the flaw as exploited but names no source. Censys found no confirmed exploitation as of October 30, and CISA does not list it. We call it reported exploited, not confirmed. If your site runs Gravity Forms, update to 3.1.3 or later today.

What happened

Who should worry

This is about WordPress websites that use the Gravity Forms plugin. If you are not sure whether your site uses it, ask your web developer or agency. Ask about this if any of these are true:

If your site does not use Gravity Forms, this notice does not apply to you.

What to do now

Do these today.

  1. Check if you have it. In your WordPress dashboard, open Plugins, then Installed Plugins, and look for "Gravity Forms." Note the version number. If it says 3.1.3 or higher, you have the fix.
  2. Update. Update Gravity Forms to 3.1.3 or later. The newest release on the Gravity Forms changelog is 3.2.1. Take a backup first, and test your forms afterwards. (Patchstack, Gravity Forms changelog)
  3. Clear your caches. After the update, ask your developer or host to clear page, object, CDN and host caches so your public forms use the updated code. This is WPDeeply's advice. (WPDeeply)
  4. If you cannot update today, ask your developer whether to switch off any form that creates posts, and especially any with a "List" custom field, until you can. This is WPDeeply's advice, not the plugin maker's. Patchstack's own advice is to update, or ask your host or developer for help. (WPDeeply, Patchstack)
  5. Check for a break-in. Updating closes the hole but does not remove anything left behind before it. Ask your developer to review recent submissions and the posts your forms created for anything unexpected, and to look for administrator accounts you do not recognize, plugins you did not install and PHP files you did not put there. WPDeeply gives the same advice. (WPDeeply)

What to send your developer, agency or host

Gravity Forms 3.1.2 and earlier has an unauthenticated PHP object injection flaw, CVE-2026-103039 (CVSS 9.8, assigned by Wordfence, published October 30, 2026). It is fixed in 3.1.3, released October 1. It is reachable through forms that create posts and use a List-type custom field with a content template. Patchstack labels it exploited but names no source; Censys found no confirmed exploitation as of October 30; CISA does not list it. Please tell us whether our site runs Gravity Forms and which version. If it is 3.1.2 or earlier, please update to 3.1.3 or later today, clear caches, and check whether any of our forms create posts with a List-type custom field. Please also review recent submissions and created posts, and check for unfamiliar administrators, plugins or PHP files, and tell us what you find. Sources: the CVE record, Patchstack, Censys, the Gravity Forms changelog.

Common questions

Has my site been hacked?

This notice does not mean your site has been hacked. It means a critical flaw has been published and a fix is out. Attacks are reported by one source and not confirmed by another.

Can EverThread tell me if I am affected?

No. EverThread does not test for this. We check your home page from the outside, the way a browser sees it. We cannot see which plugins your site runs, which versions they are on or how your forms are set up, so if our scan does not warn you about this plugin, that does not mean you are safe. Our free scan does look at your home page for other common problems, such as an expired padlock certificate, missing browser safety settings and files that should not be public.

I updated in October. Am I covered?

If your plugin shows 3.1.3 or higher, you have the fix. Plugin updates can be turned off or fail, so check the version.

I have no form that creates posts. Am I safe?

The CVE record says the flaw needs a form that creates posts. We cannot check your forms, so we cannot confirm that for your site. Update anyway.

Is it being exploited?

Reported, not confirmed. Patchstack labels it exploited and names no source. Censys found no confirmed exploitation as of October 30, and CISA does not list it. (Patchstack, Censys)

Where can I follow official updates?

The Gravity Forms changelog, Patchstack and Censys. All current notices are on our notices page.

Security alerts by email

Hear about the next one first.

When a flaw puts websites at risk, we send one plain-English email: what happened, who it affects and what to do. It's free, whether or not you use EverThread.

We email you a link to confirm first, and every alert has a one-click unsubscribe. Alerts can include a short note about EverThread. Already a customer? Use your account email and your alerts include a link to your dashboard. Privacy

Sources

While you are here

Check your site's other basics free. We look at your home page the way a browser does and tell you in plain English. This scan cannot see which WordPress plugins your site runs or which version they are on. No account.

Or sign up free and we check it every day and email you when something changes.