Scan my site freeScan free

Fix guides / Security notices

Security notice

WooCommerce store using PDF Invoice for WooCommerce? A flaw rated 9.8 needs no login. Update to 7.2.0.

Last updated: Saturday, October 31, 2026, 10:12 PM ETStatus: Fix released. No attacks reported yet. Update now.

PDF Invoice for WooCommerce + Drag and Drop Template Builder is a WordPress plugin that makes PDF invoices for WooCommerce orders. WordPress.org shows 500+ active installations. On October 30, 2026, security firm Patchstack published a critical flaw in it, and the CVE record, assigned by Wordfence, rates it 9.8 out of 10. Versions up to and including 7.1.1 can be attacked by a stranger with no login, through the note a shopper can type at checkout, and the CVE record says that can let the attacker run code on your server. Version 7.2.0, released October 28, fixes it. We found no report of attacks and CISA does not list it as exploited, but Patchstack says flaws like this are "expected to become exploited" in mass attacks. If your store runs this plugin, update to 7.2.0 or later today. If you cannot, ask your developer or host about turning it off until you can.

What happened

Who should worry

This is about WordPress websites that run WooCommerce and use the PDF Invoice for WooCommerce plugin. If you are not sure whether your site uses it, ask your web developer or agency. Ask about this if any of these are true:

Other PDF invoice plugins have similar names. This notice is only about the one named here. If your site does not use it, this notice does not apply to you.

What to do now

Do these today.

  1. Check if you have it. In your WordPress dashboard, open Plugins, then Installed Plugins, and look for "PDF Invoice for WooCommerce + Drag and Drop Template Builder." Note the version number. If it says 7.2.0 or higher, you have the fix.
  2. Update. Update the plugin to 7.2.0 or later. Take a backup first. Updating does not change the plugin's PHP minimum: the WordPress.org files list PHP 7.0 as the minimum for both 7.1.1 and 7.2.0. (Patchstack, WordPress.org)
  3. If you cannot update today, ask your developer or host whether to deactivate the plugin until you can. That is a general precaution, not the plugin maker's advice, and your invoices will stop being made while it is off. Patchstack's own advice is to update and, if you cannot, to ask your host or developer for help. (Patchstack)
  4. Check for a break-in. No signs of attack have been published, so there is nothing specific to look for. As a general check, especially if you were on 7.1.1 or earlier for several days with bank transfer or cheque payments switched on, ask your developer or host to review recent orders for unusual or very long customer notes, and to look for administrator accounts you do not recognize, plugins you did not install and PHP files you did not put there.
  5. Check your store afterwards. Place a test order and confirm the invoice still comes out as you expect.

What to send your developer, agency or host

PDF Invoice for WooCommerce + Drag and Drop Template Builder (pdf-for-woocommerce) 7.1.1 and earlier has an unauthenticated PHP object injection flaw that can lead to remote code execution, CVE-2026-109220 (CVSS 9.8, assigned by Wordfence). It is fixed in 7.2.0, released October 28. CISA does not list it as exploited, but Patchstack expects mass attacks. Please tell us whether our store runs this plugin and which version. If it is 7.1.1 or earlier, please update to 7.2.0 or later today, or deactivate it until you can. Please then review recent orders for unusual customer notes and check for unfamiliar administrators, plugins or PHP files, and tell us what you find. Sources: Patchstack, the CVE record, the GitHub advisory, WordPress.org.

Common questions

Has my store been hacked?

This notice does not mean your store has been hacked. It means a critical flaw has been published and a fix is out. We found no report of attacks.

Can EverThread tell me if I am affected?

No. EverThread does not test for this. We check your home page from the outside, the way a browser sees it. We cannot see which plugins your site runs or which versions they are on, so if our scan does not warn you about this plugin, that does not mean you are safe. Our free scan does look at your home page for other common problems, such as an expired padlock certificate, missing browser safety settings and files that should not be public.

I updated on October 29 or later. Am I covered?

If your plugin shows 7.2.0 or higher, you have the fix. Plugin updates can be turned off or fail, so check the version.

Does the update change my PHP requirements?

No. The WordPress.org plugin files list PHP 7.0 as the minimum for both 7.1.1 and 7.2.0.

Is it being exploited?

We found no report that it is, and CISA does not list it. Patchstack expects it to be exploited, and the fix has been public since October 28. (Patchstack)

Where can I follow official updates?

Patchstack and the WordPress.org changelog. All current notices are on our notices page.

Security alerts by email

Hear about the next one first.

When a flaw puts websites at risk, we send one plain-English email: what happened, who it affects and what to do. It's free, whether or not you use EverThread.

We email you a link to confirm first, and every alert has a one-click unsubscribe. Alerts can include a short note about EverThread. Already a customer? Use your account email and your alerts include a link to your dashboard. Privacy

Sources

While you are here

Check your site's other basics free. We look at your home page the way a browser does and tell you in plain English. This scan cannot see which WordPress plugins your site runs or which version they are on. No account.

Or sign up free and we check it every day and email you when something changes.